[Builder] Build failed in Jenkins: platform-builds » identity-apps #4400

cbuilder at wso2.org cbuilder at wso2.org
Mon Aug 29 08:33:41 PDT 2022


See <https://wso2.org/jenkins/job/platform-builds/job/identity-apps/4400/display/redirect>

Changes:


------------------------------------------
[...truncated 211.57 KB...]
+ nvm_iojs_prefix
+ nvm_echo iojs
+ command printf %s\n iojs
+ NVM_IOJS_PREFIX=iojs
+ [ 16.13.1 = iojs ]
+ nvm_echo 16.13.1
+ command printf %s\n 16.13.1
+ NVM_VERSION=v16.13.1
+ nvm_is_iojs_version 16.13.1
+ return 1
+ nvm_echo v16.13.1
+ command printf %s\n v16.13.1
+ PATTERN=v16.13.1
+ [ v16.13.1 = N/A ]
+ local NVM_PATTERN_STARTS_WITH_V
+ NVM_PATTERN_STARTS_WITH_V=true
+ [ true = true ]
+ nvm_num_version_groups v16.13.1
+ local VERSION
+ VERSION=v16.13.1
+ VERSION=16.13.1
+ VERSION=16.13.1
+ [ -z 16.13.1 ]
+ local NVM_NUM_DOTS
+ nvm_echo 16.13.1
+ command printf %s\n 16.13.1
+ command sed -e s/[^\.]//g
+ NVM_NUM_DOTS=..
+ local NVM_NUM_GROUPS
+ NVM_NUM_GROUPS=...
+ nvm_echo 3
+ command printf %s\n 3
+ [ _3 = _3 ]
+ nvm_is_version_installed v16.13.1
+ [ -z v16.13.1 ]
+ local NVM_NODE_BINARY
+ NVM_NODE_BINARY=node
+ nvm_get_os
+ local NVM_UNAME
+ command uname -a
+ NVM_UNAME=Linux 005c4c76d2ab 4.14.158-129.185.amzn2.x86_64 #1 SMP Tue Dec 24 03:15:32 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
+ local NVM_OS
+ NVM_OS=linux
+ nvm_echo linux
+ command printf %s\n linux
+ [ _linux = _win ]
+ nvm_version_path v16.13.1
+ [ -x /root/.nvm/versions/node/v16.13.1/bin/node ]
+ return 0
+ VERSIONS=v16.13.1
+ [  = true ]
+ [ -z v16.13.1 ]
+ nvm_echo v16.13.1
+ command printf %s\n v16.13.1
+ VERSION=v16.13.1
+ [ -z v16.13.1 ]
+ [ _v16.13.1 = _N/A ]
+ nvm_echo v16.13.1
+ command printf %s\n v16.13.1
+ VERSION=v16.13.1
+ [ v16.13.1 = N/A ]
+ nvm_make_alias default 16.13.1
+ local ALIAS
+ ALIAS=default
+ [ -z default ]
+ local VERSION
+ VERSION=16.13.1
+ [ -z 16.13.1 ]
+ nvm_echo 16.13.1
+ command printf %s\n 16.13.1
+ nvm_alias_path
+ nvm_version_dir old
+ local NVM_WHICH_DIR
+ NVM_WHICH_DIR=old
+ [ -z old ]
+ [ old = new ]
+ [ _old = _iojs ]
+ [ _old = _old ]
+ nvm_echo /root/.nvm
+ command printf %s\n /root/.nvm
+ nvm_echo /root/.nvm/alias
+ command printf %s\n /root/.nvm/alias
+ tee /root/.nvm/alias/default
+ NVM_NO_COLORS= NVM_CURRENT=v16.13.1 DEFAULT=false nvm_print_formatted_alias default 16.13.1 v16.13.1
+ local ALIAS
+ ALIAS=default
+ local DEST
+ DEST=16.13.1
+ local VERSION
+ VERSION=v16.13.1
+ [ -z v16.13.1 ]
+ local VERSION_FORMAT
+ local ALIAS_FORMAT
+ local DEST_FORMAT
+ local INSTALLED_COLOR
+ local SYSTEM_COLOR
+ local CURRENT_COLOR
+ local NOT_INSTALLED_COLOR
+ local DEFAULT_COLOR
+ local LTS_COLOR
+ nvm_get_colors 1
+ local COLOR
+ local SYS_COLOR
+ [ -n  ]
+ COLOR=0;34m
+ echo 0;34m
+ INSTALLED_COLOR=0;34m
+ nvm_get_colors 2
+ local COLOR
+ local SYS_COLOR
+ [ -n  ]
+ COLOR=0;33m
+ echo 0;33m
+ SYSTEM_COLOR=0;33m
+ nvm_get_colors 3
+ local COLOR
+ local SYS_COLOR
+ [ -n  ]
+ COLOR=0;32m
+ echo 0;32m
+ CURRENT_COLOR=0;32m
+ nvm_get_colors 4
+ local COLOR
+ local SYS_COLOR
+ [ -n  ]
+ COLOR=0;31m
+ echo 0;31m
+ NOT_INSTALLED_COLOR=0;31m
+ nvm_get_colors 5
+ local COLOR
+ local SYS_COLOR
+ [ -n  ]
+ COLOR=0;37m
+ echo 0;37m
+ DEFAULT_COLOR=0;37m
+ nvm_get_colors 6
+ local COLOR
+ local SYS_COLOR
+ [ -n  ]
+ COLOR=1;33m
+ echo 1;33m
+ LTS_COLOR=1;33m
+ ALIAS_FORMAT=%s
+ DEST_FORMAT=%s
+ VERSION_FORMAT=%s
+ local NEWLINE
+ NEWLINE=\n
+ [ _false = _true ]
+ local ARROW
+ ARROW=->
+ [ -z  ]
+ nvm_has_colors
+ local NVM_NUM_COLORS
+ nvm_has tput
+ type tput
+ tput -T vt100 colors
+ NVM_NUM_COLORS=-1
+ [ -1 -ge 8 ]
+ [ _v16.13.1 != _∞ ]
+ [ _v16.13.1 != _N/A ]
+ VERSION_FORMAT=%s *
+ [ 16.13.1 = v16.13.1 ]
+ command printf -- %s -> %s (-> %s *)\n default 16.13.1 v16.13.1
+ OUTPUT=default -> 16.13.1 (-> v16.13.1 *)
+ local EXIT_CODE
+ EXIT_CODE=0
+ nvm_echo Creating default alias: default -> 16.13.1 (-> v16.13.1 *)
+ command printf %s\n Creating default alias: default -> 16.13.1 (-> v16.13.1 *)
Creating default alias: default -> 16.13.1 (-> v16.13.1 *)
+ return 0
+ [ 0 = 1 ]
+ [ -z  ]
+ [ -n  ]
+ [ -n  ]
+ return 0
+ EXIT_CODE=0
+ set -e
+ return 0
+ which node
/root/.nvm/versions/node/v16.13.1/bin/node
+ which npm
/root/.nvm/versions/node/v16.13.1/bin/npm
+ chmod 775 /root/.nvm/versions/node/v16.13.1/bin/node
+ chmod 775 /root/.nvm/versions/node/v16.13.1/bin/npm
+ ln -s /root/.nvm/versions/node/v16.13.1/bin/node /bin/node
+ ln -s /root/.nvm/versions/node/v16.13.1/bin/npm /bin/npm
+ node --version
+ echo node version is v16.13.1
node version is v16.13.1
+ npm --version
+ echo npm version is 8.1.2
npm version is 8.1.2
[identity-apps] $ /bin/sh -xe /tmp/jenkins8673944184680908872.sh
+ curl -fsSL https://get.pnpm.io/install.sh
+ sh -
==> Extracting pnpm binaries 7.9.5
Copying pnpm CLI from /tmp/tmp.Oyz4PDghpD/pnpm to /root/.local/share/pnpm/pnpm
 ERR_PNPM_UNSUPPORTED_SHELL  Can't setup configuration for "" shell. Supported shell languages are bash, zsh, and fish.
Install Error!
Build step 'Execute shell' marked build as failure
[identity-apps] $ /usr/bin/env bash /tmp/jenkins3050261174966193203.sh
npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: @wso2is/webapps at 1.4.67
npm ERR! Found: @typescript-eslint/parser at 4.33.0
npm ERR! node_modules/@typescript-eslint/parser
npm ERR!   dev @typescript-eslint/parser@"^4.17.0" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer @typescript-eslint/parser@"^5.29.0" from @nrwl/eslint-plugin-nx at 14.4.2
npm ERR! node_modules/@nrwl/eslint-plugin-nx
npm ERR!   dev @nrwl/eslint-plugin-nx@"14.4.2" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 
npm ERR! See /root/.npm/eresolve-report.txt for a full report.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2022-08-29T15_33_32_121Z-debug.log

> @wso2is/webapps at 1.4.67 update-version
> node scripts/update-version.js "jenkins=true" "build=#4400" "pom=1.4.67"

node:internal/modules/cjs/loader:936
  throw err;
  ^

Error: Cannot find module 'fs-extra'
Require stack:
- <https://wso2.org/jenkins/job/platform-builds/job/identity-apps/ws/scripts/update-version.js>
    at Function.Module._resolveFilename (node:internal/modules/cjs/loader:933:15)
    at Function.Module._load (node:internal/modules/cjs/loader:778:27)
    at Module.require (node:internal/modules/cjs/loader:1005:19)
    at require (node:internal/modules/cjs/helpers:102:18)
    at Object.<anonymous> (<https://wso2.org/jenkins/job/platform-builds/job/identity-apps/ws/scripts/update-version.js>:30:12)
    at Module._compile (node:internal/modules/cjs/loader:1101:14)
    at Object.Module._extensions..js (node:internal/modules/cjs/loader:1153:10)
    at Module.load (node:internal/modules/cjs/loader:981:32)
    at Function.Module._load (node:internal/modules/cjs/loader:822:12)
    at Function.executeUserEntryPoint [as runMain] (node:internal/modules/run_main:81:12) {
  code: 'MODULE_NOT_FOUND',
  requireStack: [
    '<https://wso2.org/jenkins/job/platform-builds/job/identity-apps/ws/scripts/update-version.js'>
  ]
}
Build step 'Execute shell' marked build as failure


More information about the Builder mailing list